Tp : Expériences à 3 issues & loi trinomiale





télécharger 29.99 Kb.
titreTp : Expériences à 3 issues & loi trinomiale
date de publication09.01.2019
taille29.99 Kb.
typeDocumentos
d.20-bal.com > loi > Documentos

TP : Expériences à 3 issues & loi trinomiale

« Le jeu de la roue »


Objectifs :

  • Représenter la répétition d’expériences identiques et indépendantes à 3 issues par un arbre pondéré.

  • Calculer la loi de probabilité d’une variable aléatoire qui suit une loi trinomiale.

  • Construire et exécuter un algorithme pour calculer une probabilité.

Niveaux : 1ère S et 1ère ES/L

Durée : 2h (1h sur papier- travail individuel / 1h pour écrire tester l’algorithme– travail en groupe)

Prérequis :

  • Décrire une expérience à l’aide d’un arbre.

  • Calculer une loi de probabilité.

  • Bases de l’algorithme(Déclaration de variables / Boucles/ Conditions / Affichage).

Outils TICE : Logiciel de programmation : Algobox

Référence au programme :

programme.bmp

Déroulement :

On répète n fois de manière identique et indépendante l’expérience « tourner la roue », et on note la couleur obtenue. Trois issues sont possibles : on peut obtenir la couleur Rouge, Verte ou Bleue.

L’activité se déroule en deux temps :

  • Dans une première partie, l’élève étudie une situation à 3 issues et 3 répétitions en complétant un arbre.

Puis on introduit X la variable aléatoire définit par la règle du jeu suivante : le joueur gagne 2€ si au bout de n expériences, la couleur rouge n’est jamais apparue, il gagne 5€ si la couleur rouge apparaît une seule fois, et perd 1€ si elle apparaît plus d’une fois. On va alors calculer P(X=-1), P(X=2) et P(X=5).

X pouvant prendre 3 valeurs, on parlera de loi trinomiale.

  • On se rend vite compte que l’arbre a ses limites. Sa représentation devient impossible lorsque le nombre de répétition de l’expérience augmente. C’est pourquoi dans la deuxième partie, on veut généraliser le nombre de répétition à n, et écrire un algorithme permettant de calculer la probabilité des 3 gains du jeu.

L’algorithme étant complexe et assez long (plusieurs boucles et conditions), il est préférable de mettre en place un travail de groupes.

Enoncé :

_ Mr Hazard tourne la roue de casino représentée ci-contre.

_ L’expérience consiste à tourner n fois la roue et à regarder la couleur obtenue à chaque fois.

_ On tombe sur la portion bleue avec une probabilité de ,

la portion verte avec une probabilité de

et la portion rouge avec une probabilité de .

_ Soit X la variable aléatoire définie par la règle du jeu suivante : le joueur gagne 2€ si au bout de n expériences, la couleur rouge n’est jamais apparue, il gagne 5€ si la couleur rouge apparaît une seule fois, et perd 1€ si elle apparaît plus d’une fois.

Quel que soit le nombre n d’expériences (répétées de manières identiques et indépendantes), X peut donc prendre 3 valeurs : X=-1 , X=2 ou X=5.

La loi de probabilité de la variable aléatoire X se nomme loi trinomiale.


roue.bmp






  1. Cas où n=3 et arbre de probabilité

  1. Reproduire et compléter l’arbre ci-contre afin d’obtenir tous les chemins possibles.



  1. Dans le tableau suivant, reporter le nombre de chemins réalisant chaque suite de couleurs, sans tenir compte de l’ordre.

Chemins possibles

(sans ordre)

B-B-B

V-V-V

R-R-R

B-V-R

V-V-B

V-V-R

R-R-B

R-R-V

B-B-R

B-B-V

Total

Nombre de chemins

1

1

1

6

3

3

3

3

3

3

27

Remarque : On vérifiera que le nombre total de chemins trouvé est cohérent avec l’arbre ci-dessus.

  1. Quelle est la probabilité que Mr Hazard obtienne dans l’ordre les couleurs « Rouge-Bleu-Vert »?

.

  1. Mr Hazard dit qu’il gagnerait plus facilement la partie si le jeu consistait à avoir la combinaison « Rouge-Bleu-Vert » dans n’importe quel ordre. Pourquoi a-t-il raison ? Quelle est cette probabilité ?

Il a raison car plusieurs chemins sont possibles : 6 d’après l’arbre ou le tableau.

.

  1. Mr Hazard est gagnant s’il obtient un unique Rouge. Quelle est la probabilité qu’il gagne au jeu de la roue?

Rappelons que X est la variable aléatoire qui prend la valeur 5 si la couleur rouge apparaît une seule fois.

Toutes les possibilités pour gagner sont, dans le désordre : R-V-V , R-B-B, R-V-B



.

  1. Compléter la loi de probabilité de X.

xi

-1

2

5

P(X=xi)









.



.

  1. Généralisation et programmation

On se rend vite compte que l’arbre a ses limites : sa représentation devient impossible lorsque le nombre de répétition de l’expérience augmente (le nombre de branches est de 3n !). C’est pourquoi dans la deuxième partie, on veut généraliser le nombre de répétitions à n, et écrire un algorithme permettant de calculer les probabilités de chaque gain.

Travail de groupe demandé :

  • A l’aide des indications des deux paragraphes ci-dessous, écrire un algorithme permettant de calculer et d’afficher P(X=-1), P(X=2) et P(X=5).

  • Puis, utiliser le logiciel Algobox pour programmer cet algorithme. Vérifier le résultat de la question f précédente.

  • Quelle est la probabilité que M. Hazard gagne 5€ en tournant 10 fois la roue ?

  • Que constatez-vous lorsque l’on fait augmenter le nombre d’expériences n ?




  1. Principe de l’algorithme 



  • Une grande partie de la programmation consiste à construire l’arbre.

On choisit tout d’abord l’ordre suivant pour explorer  l’arbre :

Rouge-Vert-Bleu.

Cela signifie que l’on va parcourir les branches partant d’un nœud Rouge dans un premier temps, puis les branches avec un nœud Vert et enfin Bleu.

Ainsi, la première branche parcourue sera Rouge-Rouge-Rouge et la dernière : Bleu-Bleu-Bleu.

Ci-contre : exemple de l’ordre de parcours pour n=2 (lire l’arbre de bas en haut)

  • A chaque fois qu’une branche est terminée, on compte le nombre de « Rouge » puis on évalue le gain (X=-1, X=2 ou X=5).



  • Ensuite, il faut calculer la probabilité de réaliser la branche.



  • Puis, on fait la somme des probabilités de toutes les banches qui ont le même gain.



  • L’algorithme affiche en dernier les 3 probabilités :

  • la probabilité de perdre 1€ (si la couleur Rouge est apparue plus d’une fois) : variable S.

  • la probabilité de gagner 2€ (si le Rouge n’est jamais apparu) : variable Q.

  • et la probabilité de gagner 5€ (si le Rouge est apparu exactement une fois) : variable R.

  • Comme Algobox ne considère que les nombres, on identifie la couleur Rouge à 1, la couleur Verte à 2 et la couleur Bleue à 3.





  1. Variables et initialisations



  • S, Q, R initialisés à 0.

  • Demander n (nombre d’expériences)

  • Liste L de taille n (initialisés à n cases rouges)

  • Combinaison est une variable booléenne : 0 si Faux, 1 si Vraie. Si on vient de changer le rouge en vert ou le vert en bleu, combinaison vaut 1, par contre, lors d’un changement de nœud, combinaison vaut 0.

Combinaison est initialisée à 0.

  • La variable booléenne continueBoucle vaut 1 tant que la dernière combinaison Bleu-Bleu-Bleu n’a pas été générée (et 0 sinon).

continueBoucle est initialisée à 1

  • Les variables i et indice balayent la liste de 1 à n.

  • La variable compteur initialisée à 0 compte le nombre de « Rouge », une fois une branche terminée.

  • La variable proba (initialisée à 1) calcule la probabilité d’obtenir le tirage de la liste L, une branche étant terminée.

  1. Solution : Algorithme

  • Déclarer 3 variables : S, Q, R

  • Créer liste L de taille n.

  • Déclarer variable continueBoucle

  • Déclarer proba (nombre) et compteur (nombre)

  • Début programme

  • Initialiser S :=0, Q :=0 et R :=0.

  • Demander n (nombre d’expériences).

  • Initialiser liste : toutes les cases rouges de 1 à n.

Pour i de 1 à n, L[i] :=1 ; finPour

  • Initialiser continueBoucle := 1 (vraie)

  • Déclarer proba (nombre) et compteur (nombre)

  • Tant que (continueBoucle =1) faire :

  • proba := 1 (initialisation de la probabilité d’obtenir le tirage de la liste L)

  • compteur := 0 (compte le nombre de Rouge dans la liste)

  • Pour i allant de 1 à n

  • Si L[i] =1 (Rouge) alors Compteur := compteur +1 ; , FinSi

  • Si L[i] =2 (Vert) alors , FinSi

  • Si L[i] =3 (Bleu) alors , FinSi

Fin Pour

  • Si compteur = 0 alors Q := Q + proba, FinSi

  • Si compteur = 1 alors R := R + proba, FinSi

  • Si compteur > 1 alors S := S + proba , FinSi

  • continueBoucle := 0 (Faux)

  • Pour i allant de 1 à n

  • Si L[i] (Bleu) alors continueBoucle := 1 (vraie) (On s’arrête quand tout est bleu).

FinPour

  • Si continueBoucle =1

  • Définir variable Indice Indice (nombre de 1 à n) et combinaison (booléen)

  • Indice := 1 et combinaison := 0 (faux)

  • Tant que (Indice <=n) et (combinaison = 0) faire

  • Si L[Indice] = 1 (Rouge) alors L[indice]=2 (Vert) ; combinaison :=1 ; FinSi

  • Si Si L[Indice] = 2 (Vert) alors L[indice]=3 (Bleu) ; combinaison :=1 ; FinSi

  • Si L[Indice] = 3 (Bleu) alors L[indice]=1 (Rouge) ; Indice := Indice + 1 ; FinSi

Fin Tant que

Fin Si

Fin Tant que

_ Afficher : « la probabilité de perdre 1€ est de : », S

_ Afficher : « la probabilité de gagner 2€ est de : », Q

_ Afficher : « la probabilité de gagner 5€ est de : », R.

_ Fin Programme.

  1. Solution : Programmation avec AlgoBox

algo1.bmp

code2.bmp





  1. Observations lorsque n augmente

_ Pour n=10, le programme donne le résultat suivant :


_ A partir de 4 expériences, on n’a plus de chance de perdre 1€.


Groupe TICE Grenoble _ Fiche professeur Page


similaire:

Tp : Expériences à 3 issues & loi trinomiale iconAdresse : union sportive fontenaysienne
«Madelin» conformément aux dispositions issues de la loi n°94-126 du 11 février 1994

Tp : Expériences à 3 issues & loi trinomiale iconReactus de l’afec
«Pratiques restrictives de concurrence comment comprendre et interpréter les nouvelles règles issues de la loi Hamon ?»

Tp : Expériences à 3 issues & loi trinomiale iconLes dispositions entre crochets sont issues soit de propositions...

Tp : Expériences à 3 issues & loi trinomiale iconRapport Final Deuxième colloque international «L'assurance qualité...
«L'assurance qualité dans l'enseignement supérieur : «Expériences de mise en œuvre, indicateurs de performance et prospective»

Tp : Expériences à 3 issues & loi trinomiale iconRépétition d'expériences identiques et indépendantes

Tp : Expériences à 3 issues & loi trinomiale iconRépétition d'expériences identiques et indépendantes

Tp : Expériences à 3 issues & loi trinomiale iconConsultant – chef de projet experiences professionnelles

Tp : Expériences à 3 issues & loi trinomiale iconExercice 3 ( 5 points ) On réalise les expériences 1 et 2 schématisées ci-dessous : Expérience 1

Tp : Expériences à 3 issues & loi trinomiale iconLe Programme d’Appui aux projets des Organisations de Solidarité...

Tp : Expériences à 3 issues & loi trinomiale iconPrésentation
«évaluation classique» sont issues d’une épreuve de baccalauréat récentes; d’autres ont été élaborées spécialement pour ce document,...






Tous droits réservés. Copyright © 2016
contacts
d.20-bal.com